use strict;
my $str = '1111111c/1111111
11a/111b
11/11a
11/112
111121112
1111111C/
1111111c/
/1111111c
ccccccc/11111
1111/cccc';
my $regex = qr/[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}