import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<meta.*property=\"og:image\".*content=\"(.*)\".*\\/>";
final String string = "<meta property=\"og:image\" content=\"http://www.moneycontrol.com/news_image_files/2013/s/Syrian_diesel_trucks_190.jpg\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}