// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<meta.*property="og:image".*content="(.*)".*\/>"#).unwrap();
let string = "<meta property=\"og:image\" content=\"http://www.moneycontrol.com/news_image_files/2013/s/Syrian_diesel_trucks_190.jpg\" />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}