const regex = /<meta.*property="og:image".*content="(.*)".*\/>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<meta.*property="og:image".*content="(.*)".*\\\/>', '')
const str = `<meta property="og:image" content="http://www.moneycontrol.com/news_image_files/2013/s/Syrian_diesel_trucks_190.jpg" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}