import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public*[ ]enum*[ ]DynamicVocabularyName[ ]*\\{([\\ \\n\\r\\t]*([A-Z\\_]*)[ ]*\\,)*[\\ \\n\\r\\t]*";
final String string = "package com.motorolasolutions.vip.datatypes.names;\n\n"
+ "public enum DynamicVocabularyName {\n"
+ " ACTIVE_CRIMES_COUNT,\n"
+ " ACTIVE_CRIME_TYPE,\n"
+ " APPLICATION_NAME,\n"
+ " ARREST_COUNT,}\n"
+ " AREA_DESCRIPTION,\n"
+ " AREA_NAME,\n"
+ " BAD_PARAMETER_NAME,\n"
+ " BATTERY_PERCENT,\n"
+ " CAROWNER_PERSON_ADDRESS,\n"
+ " CAROWNER_PERSON_FULLNAME,\n"
+ " CAROWNER_PERSON_PHONE,\n"
+ " CRIME_DATE_DESCRIPTION,\n"
+ " CRIME_SUBTYPE,\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}