# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"public*[ ]enum*[ ]DynamicVocabularyName[ ]*{([\ \n\r\t]*([A-Z\_]*)[ ]*\,)*[\ \n\r\t]*"
test_str = ("package com.motorolasolutions.vip.datatypes.names;\n\n"
"public enum DynamicVocabularyName {\n"
" ACTIVE_CRIMES_COUNT,\n"
" ACTIVE_CRIME_TYPE,\n"
" APPLICATION_NAME,\n"
" ARREST_COUNT,}\n"
" AREA_DESCRIPTION,\n"
" AREA_NAME,\n"
" BAD_PARAMETER_NAME,\n"
" BATTERY_PERCENT,\n"
" CAROWNER_PERSON_ADDRESS,\n"
" CAROWNER_PERSON_FULLNAME,\n"
" CAROWNER_PERSON_PHONE,\n"
" CRIME_DATE_DESCRIPTION,\n"
" CRIME_SUBTYPE,\n"
"}")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.