import Foundation
let pattern = #"public*[ ]enum*[ ]DynamicVocabularyName[ ]*{([\ \n\r\t]*([A-Z\_]*)[ ]*\,)*[\ \n\r\t]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
package com.motorolasolutions.vip.datatypes.names;
public enum DynamicVocabularyName {
ACTIVE_CRIMES_COUNT,
ACTIVE_CRIME_TYPE,
APPLICATION_NAME,
ARREST_COUNT,}
AREA_DESCRIPTION,
AREA_NAME,
BAD_PARAMETER_NAME,
BATTERY_PERCENT,
CAROWNER_PERSON_ADDRESS,
CAROWNER_PERSON_FULLNAME,
CAROWNER_PERSON_PHONE,
CRIME_DATE_DESCRIPTION,
CRIME_SUBTYPE,
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}