package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\/]+)(\/.*.(js|css))$`)
var str = `1393435108/js/prototype/prototype.js,/js/prototype/window.js./,/js/scriptaculous/builder.js,/js/scriptaculous/effects.js,/js/scriptaculous/dragdrop.js,/js/scriptaculous/controls.js,/js/scriptaculous/slider.js,/js/lib/ccard.js,/js/prototype/validation.js,/js/varien/js.js,/js/mage/translate.js,/js/mage/adminhtml/hash.js,/js/mage/adminhtml/events.js,/js/mage/adminhtml/loader.js,/js/mage/adminhtml/grid.js,/js/mage/adminhtml/tabs.js,/js/mage/adminhtml/form.js,/js/mage/adminhtml/accordion.js,/js/mage/adminhtml/tools12345.js`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}