// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^\/]+)(\/.*.(js|css))$").unwrap();
let string = "1393435108/js/prototype/prototype.js,/js/prototype/window.js./,/js/scriptaculous/builder.js,/js/scriptaculous/effects.js,/js/scriptaculous/dragdrop.js,/js/scriptaculous/controls.js,/js/scriptaculous/slider.js,/js/lib/ccard.js,/js/prototype/validation.js,/js/varien/js.js,/js/mage/translate.js,/js/mage/adminhtml/hash.js,/js/mage/adminhtml/events.js,/js/mage/adminhtml/loader.js,/js/mage/adminhtml/grid.js,/js/mage/adminhtml/tabs.js,/js/mage/adminhtml/form.js,/js/mage/adminhtml/accordion.js,/js/mage/adminhtml/tools12345.js";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}