package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\-[a-z]|\_[a-z])`)
var str = `this-is-a-test`
var substitution = "\U$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}