$re = '/(\-[a-z]|\_[a-z])/m';
$str = 'this-is-a-test';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;