use strict;
my $str = 'this-is-a-test';
my $regex = qr/(\-[a-z]|\_[a-z])/mp;
my $subst = '\\U$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";