import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http|https|ftp|ftps)\\:\\/\\/|www\\.|)[a-zA-Z0-9\\-\\.]+(\\.[a-zA-Z]{2,3}|\\.pl|\\.net|\\.com)(\\/\\S*)?";
final String string = "xtalent.net\n\n"
+ "www.xtalent.org\n\n\n"
+ "https://xtalent.net\n\n"
+ "talent.wp.pl\n\n"
+ "ising.pl\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}