import re
regex = re.compile(r"((http|https|ftp|ftps)\:\/\/|www\.|)[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3}|\.pl|\.net|\.com)(\/\S*)?")
test_str = ("xtalent.net\n\n"
"www.xtalent.org\n\n\n"
"https://xtalent.net\n\n"
"talent.wp.pl\n\n"
"ising.pl\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")