// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((http|https|ftp|ftps)\:\/\/|www\.|)[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3}|\.pl|\.net|\.com)(\/\S*)?").unwrap();
let string = "xtalent.net
www.xtalent.org
https://xtalent.net
talent.wp.pl
ising.pl
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}