using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?>[^\\""]++|\\.)*+""";
string input = @"hello, ""world""
this is ""a string with an \""inner\"" string and a \\ backslash"" !
empty string: ""
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}