re = /"(?>[^\\"]++|\\.)*+"/
str = 'hello, "world"
this is "a string with an \\"inner\\" string and a \\\\ backslash" !
empty string: ""
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end