import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?>[^\\\\\"]++|\\\\.)*+\"";
final String string = "hello, \"world\"\n"
+ "this is \"a string with an \\\"inner\\\" string and a \\\\ backslash\" !\n"
+ "empty string: \"\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}