const regex = /[^=;]+(?<!TEST.)=[^;]+(?:$|;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^=;]+(?<!TEST.)=[^;]+(?:$|;)', 'gm')
const str = `TESTA=abc; VAL2=def; TESTB=ghi; TESTC=jkl; VAL2=bla1; VAL3=bla2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}