re = /[^=;]+(?<!TEST.)=[^;]+(?:$|;)/m
str = 'TESTA=abc; VAL2=def; TESTB=ghi; TESTC=jkl; VAL2=bla1; VAL3=bla2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end