package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)('.*?'|".*?"|\S+)`)
var str = `Class 'Occultist'ssss Vestment "Occultist's Vestment" "Occultist's" Vestment`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}