$re = '/(\'.*?\'|".*?"|\S+)/m';
$str = 'Class \'Occultist\'ssss Vestment "Occultist\'s Vestment" "Occultist\'s" Vestment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);