#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?(((((([hH]?[tT]?)|[fF]?)[tT]?[pP]?s?:?)?(\/\/)?|[A-Za-z]+|(\/\/)?)?[A-Za-z]+)\.\S+(\/|\.|#)\S+)(?!(\.com))\)?"
Local $sString = "DONT MATCH $200.00/month... for positioningacceleratorprogram.com " & @CRLF & _
"on youtube.com eeeee https://www. //www. or not def//: :google.com ://google.com google.com or ld/2018/01/02/mountains-u-s-recycling-pile-up-china-restricts-imports/995134001/" & @CRLF & _
"atis:theexpertiseincubator.simplecast.fm/ This" & @CRLF & _
"" & @CRLF & _
"MATCH " & @CRLF & _
"www.google.com" & @CRLF & _
"https://wWw.csis.org" & @CRLF & _
"http://youtu.be/abS#PS9 " & @CRLF & _
"hotshot.io#hash" & @CRLF & _
"htTps://buFf.ly/2as34vz/MN" & @CRLF & _
"https://www.usatoday.com/story/news/wor " & @CRLF & _
"www.asas.io" & @CRLF & _
"doggie.io/x doggie.io#taggie usatoday.com/story/news/world/2018/01/02/mountains-u-s-recycling-pile-up-china-restricts-imports/995134001/" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"htt://www.google.com" & @CRLF & _
"://www.google.com" & @CRLF & _
"here: forms.gle/7j6rFkUjbKXr2skC6 A few again: forms.gle/7j6rFkUjbKXr2skC6 -P (yet): www.acrecoffee.com/shop coffee (nmpinoncoffee.com/products/Traditional%20Piñon?category=coffee0) and (Readin' time: 33 seconds) This is interesting: www.cnbc.com/2019/04/26/the-15-us-jobs-disappearing-the-fastest.html Not of this htfps:theexpertiseincubator.simplecast.fm/ This" & @CRLF & _
"httPs:theexpertiseincubator.simplecast.fm/ This" & @CRLF & _
" Life: https://www.thisamericanlife.org/7/quitting Frequency, audience: offlinepodcast.rocks/paid-acquisitions (the setup) offlinepodcast.rocks/podcast-listeners (the payoff)." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")