import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?(((((([hH]?[tT]?)|[fF]?)[tT]?[pP]?s?:?)?(\\/\\/)?|[A-Za-z]+|(\\/\\/)?)?[A-Za-z]+)\\.\\S+(\\/|\\.|#)\\S+)(?!(\\.com))\\)?";
final String string = "DONT MATCH $200.00/month... for positioningacceleratorprogram.com \n"
+ "on youtube.com eeeee https://www. //www. or not def//: :google.com ://google.com google.com or ld/2018/01/02/mountains-u-s-recycling-pile-up-china-restricts-imports/995134001/\n"
+ "atis:theexpertiseincubator.simplecast.fm/ This\n\n"
+ "MATCH \n"
+ "www.google.com\n"
+ "https://wWw.csis.org\n"
+ "http://youtu.be/abS#PS9 \n"
+ "hotshot.io#hash\n"
+ "htTps://buFf.ly/2as34vz/MN\n"
+ "https://www.usatoday.com/story/news/wor \n"
+ "www.asas.io\n"
+ "doggie.io/x doggie.io#taggie usatoday.com/story/news/world/2018/01/02/mountains-u-s-recycling-pile-up-china-restricts-imports/995134001/\n"
+ "https://www.google.com\n"
+ "http://www.google.com\n"
+ "www.google.com\n"
+ "htt://www.google.com\n"
+ "://www.google.com\n"
+ "here: forms.gle/7j6rFkUjbKXr2skC6 A few again: forms.gle/7j6rFkUjbKXr2skC6 -P (yet): www.acrecoffee.com/shop coffee (nmpinoncoffee.com/products/Traditional%20PiƱon?category=coffee0) and (Readin' time: 33 seconds) This is interesting: www.cnbc.com/2019/04/26/the-15-us-jobs-disappearing-the-fastest.html Not of this htfps:theexpertiseincubator.simplecast.fm/ This\n"
+ "httPs:theexpertiseincubator.simplecast.fm/ This\n"
+ " Life: https://www.thisamericanlife.org/7/quitting Frequency, audience: offlinepodcast.rocks/paid-acquisitions (the setup) offlinepodcast.rocks/podcast-listeners (the payoff).\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}