import re
regex = re.compile(r" +(?=[A-Z\d])", flags=re.MULTILINE)
test_str = ("1.6.1 Members................................................................ 12\n"
"1.6.2 Accessibility.......................................................... 13\n"
"1.6.3 Type parameters........................................................ 13")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")