re = / +(?=[A-Z\d])/m
str = '1.6.1 Members................................................................ 12
1.6.2 Accessibility.......................................................... 13
1.6.3 Type parameters........................................................ 13'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end