package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[\p{L} -]+$)`)
var str = `my string is nice 123 and it is cool
regular string
this is fine too
this however, is not`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}