re = /(^[\p{L} -]+$)/m
str = 'my string is nice 123 and it is cool
regular string
this is fine too
this however, is not'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end