package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){4}$|.*\.local|.*local\.|.*localhost|.*\.internal|.*csb.|.*codesandbox|.*lvh\.me|.*.ngrok.|.*nip\.io|.*.test).*`)
var str = `http://localhost:9999
https://localhost:0000
http://stackoverflow.com/challenge
https://arseniyaskingquestion.ru/SO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}