const regex = new RegExp('https?:\\/\\/((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){4}$|.*\\.local|.*local\\.|.*localhost|.*\\.internal|.*csb.|.*codesandbox|.*lvh\\.me|.*.ngrok.|.*nip\\.io|.*.test).*', 'gm')
const str = `http://localhost:9999
https://localhost:0000
http://stackoverflow.com/challenge
https://arseniyaskingquestion.ru/SO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}