import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){4}$|.*\\.local|.*local\\.|.*localhost|.*\\.internal|.*csb.|.*codesandbox|.*lvh\\.me|.*.ngrok.|.*nip\\.io|.*.test).*";
final String string = "http://localhost:9999\n"
+ "https://localhost:0000\n"
+ "http://stackoverflow.com/challenge\n"
+ "https://arseniyaskingquestion.ru/SO";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}