using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\brecord {[^{}]*my_id_[123][^{}]*}";
string input = @"record {
record {
id my_id_1
my_name_1
}
record {
id my_id_2
my_name_2
}
record {
id my_id_3
my_name_3
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}