import re
regex = re.compile(r"\brecord {[^{}]*my_id_[123][^{}]*}", flags=re.MULTILINE)
test_str = ("record {\n"
" record {\n"
" id my_id_1\n"
" my_name_1\n"
" }\n\n"
" record {\n"
" id my_id_2\n"
" my_name_2\n"
" }\n\n"
" record {\n"
" id my_id_3\n"
" my_name_3\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")