#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"([^0-9][^"]*)":"
Local $sString = "props: {" & @CRLF & _
" "label": "1rem"," & @CRLF & _
" "text3": "1rem"," & @CRLF & _
" "text2Button": "1rem"," & @CRLF & _
" "1": "1rem"," & @CRLF & _
" "5spacing": 2" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")