import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^0-9][^\"]*)\":";
final String string = "props: {\n"
+ " \"label\": \"1rem\",\n"
+ " \"text3\": \"1rem\",\n"
+ " \"text2Button\": \"1rem\",\n"
+ " \"1\": \"1rem\",\n"
+ " \"5spacing\": 2\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}