const regex = /rgba\((\d+, \d+, \d+), \d+\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rgba\\((\\d+, \\d+, \\d+), \\d+\\)', 'gm')
const str = `rgba(168, 210, 100, 1)`;
const subst = `rgb\(\1\)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);