$re = '/rgba\((\d+, \d+, \d+), \d+\)/m';
$str = 'rgba(168, 210, 100, 1)';
$subst = "rgb\(\1\)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;