package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/\S+`)
var str = `Lorem ipsum dolor sit amet, consetetur sadipscing http://www.loremipsum.com/asd/fgh/jkl elitr, sed diam `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}