re = /https?:\/\/\S+/
str = 'Lorem ipsum dolor sit amet, consetetur sadipscing http://www.loremipsum.com/asd/fgh/jkl elitr, sed diam '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end