package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?P<company>[^|]+?)\s*\|\s*(?P<title>[^|]+?)\s*\|\s*(?P<locations>[^|]+?)\s*(?:\|\s*(?P<attrs>.+))?$`)
var str = `Binti | San Francisco, CA | Software Engineer | Full-time, onsite, will transfer H-1B | $100K – $140K, 0.25% – 1.0%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}