const regex = /\s*(?P<company>[^|]+?)\s*\|\s*(?P<title>[^|]+?)\s*\|\s*(?P<locations>[^|]+?)\s*(?:\|\s*(?P<attrs>.+))?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?P<company>[^|]+?)\\s*\\|\\s*(?P<title>[^|]+?)\\s*\\|\\s*(?P<locations>[^|]+?)\\s*(?:\\|\\s*(?P<attrs>.+))?$', 'g')
const str = `Binti | San Francisco, CA | Software Engineer | Full-time, onsite, will transfer H-1B | \$100K – \$140K, 0.25% – 1.0%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}