$re = '/\s*(?P<company>[^|]+?)\s*\|\s*(?P<title>[^|]+?)\s*\|\s*(?P<locations>[^|]+?)\s*(?:\|\s*(?P<attrs>.+))?$/';
$str = 'Binti | San Francisco, CA | Software Engineer | Full-time, onsite, will transfer H-1B | $100K – $140K, 0.25% – 1.0%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);