using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([a-zA-Z0-9]+,[a-zA-Z0-9]+\)";
string input = @"String test = ""(test1,test2)"";
""(test1,t)""
String test = ""(t,test2)"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}