$re = '/\([a-zA-Z0-9]+,[a-zA-Z0-9]+\)/m';
$str = 'String test = "(test1,test2)";
"(test1,t)"
String test = "(t,test2)";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);