re = /\([a-zA-Z0-9]+,[a-zA-Z0-9]+\)/m
str = 'String test = "(test1,test2)";
"(test1,t)"
String test = "(t,test2)";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end