re = /(__nls__)(.*?)(INR)/
str = '__nls__Cancellation permitted 03 Hrs before scheduled departure __nls__ Within 03-72 hrs INR 3,500 or 100% of airfare charge (whichever is lower) __nls__ Before 72 hrs INR 3,000 or 100% of airfare charge (whichever is lower)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end