import Foundation
let pattern = #"(__nls__)(.*?)(INR)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"__nls__Cancellation permitted 03 Hrs before scheduled departure __nls__ Within 03-72 hrs INR 3,500 or 100% of airfare charge (whichever is lower) __nls__ Before 72 hrs INR 3,000 or 100% of airfare charge (whichever is lower)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}