using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Expand\R([\w'\-]+)\h*,\h*([\w'\-]+)";
string input = @"Expand
Bohrer, Phyllis
Expand
Bohrer , Phyllis
Expand
Bohrer , Phyllis ,
Expand
O'conner, Phyllis-Adams ,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}