re = /Expand\R([\w'\-]+)\h*,\h*([\w'\-]+)/m
str = 'Expand
Bohrer, Phyllis
Expand
Bohrer , Phyllis
Expand
Bohrer , Phyllis ,
Expand
O\'conner, Phyllis-Adams ,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end