$re = '/Expand\R([\w\'\-]+)\h*,\h*([\w\'\-]+)/m';
$str = 'Expand
Bohrer, Phyllis
Expand
Bohrer , Phyllis
Expand
Bohrer , Phyllis ,
Expand
O\'conner, Phyllis-Adams ,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);